midi configuration help

Discussion in 'LivePRO' started by javiluz, Aug 21, 2009.

  1. javiluz

    javiluz Member

    Hello,

    I am trying to use a midi controler(elc sidekick fader10) with livepro.
    For some reason I am able only to setup functions on the "special keys" at midi settings but when I try to assign a funcion on "Midi to sliders" no midi note will show or get saved. I need to use at least 5 functions from this menu.
    Also for my way of working it will be great to be able to assing four midi buttons to turn on and of any of the four live tracks individually. is it possible?

    thnks a lot
    javiluz
     
  2. Pangolin

    Pangolin Staff Member

    I hope another user can comment on this. I believe another user also had a problem, but was able to solve it with some setting that was on the device itself.

    LivePRO does give you a clue as to what is happening. When MIDI messages come in, there are "numbers" that are seen down near the virtual keyboard on the LivePRO screen. Those "numbers" correspond to the MIDI data that is received. You may decode those numbers yourself which may reveal what is going on (that's what the other user did), or send us an email with information about those "numbers" and we'll try to help.

    Best regards,

    William Benner
     
  3. javiluz

    javiluz Member

    Hello again,

    Finally I have the sidekick fader10 working with livePro on Windows Vista.
    But I need some help with a few things.

    My Midi device works perfect when I do the setup for the special keys tab at the midi window. (picture1)
    But when I try to assign the midi to slider tab, no note will show at this window but the midi numbers on the virtual midi keyboard at livePro move as I press the buttons or faders. (picture 2)

    Any help will be apreciated
    thnks a lot

    javiluz
     

    Attached Files:

  4. Pangolin

    Pangolin Staff Member

    Dear Javiluz,

    We have looked at this and did some testing. Our guess is that you are trying to assign MIDI Notes to a SLIDER function. Sliders respond only to "control change", not to MIDI notes.

    We are not familiar with this particular console, but we guess he has some special MIDI device, and instead of sending ControlChange or PitchBand, it is sending NOTE messages. It may be possible for you to reconfigure that particular device to send ControlChange messages instead of NOTE messages.

    For us to help you further, we will need to know what messages this device is sending while you are manipulating those controls.

    LivePRO has a simple MIDI monitor. It has a little blue label under the Grid. If you move a slider and you see the numbers with "8" or "9", then our assumption is correct that the slider is sending NOTE messages instead of control related messages. If this is indeed the case, then we ourselves can't do anything to solve it since the console is putting out non-standard messages for a control. However, as I wrote above, you may be able to reconfigure this console (using some kind of settings or whatever).

    Yes it is possible and other users do this very thing. This is what we recommend you do:

    Each cue has a Global Note assignment. You will find this in the "Others" panel of the cue properties. This will allow you to make a link between a specific MIDI Note and a specific Cue. The next step - define a command inside this Cue. For example - Track 1- Toggle Active state.

    Best regards,

    William Benner
     
  5. Pangolin

    Pangolin Staff Member

    Dear Javiluz,

    Based on what you wrote above, we have added some additional logging features to LivePRO. Please contact us directly to receive this new version of LivePRO, so we can figure out what MIDI messages you are receiving.

    Best regards,

    William Benner
     

Share This Page