FB3 Problem or PC/USB issue?

Discussion in 'Lasershow Designer QuickShow' started by PhillD, Oct 7, 2011.

  1. PhillD

    PhillD Beta Tester

    Hi,

    I use Pangolin software for both DMX and Laser controls and I have been having a problem for quite a while. If I am running DMX cues for a long time, and not using the laser, the FB3 loses it's connection to the PC and the laser will not display any output. When the problem occurs, the green light on the FB3 hardware is lit, the orange is sometimes lit and the red is never lit. When I go into the hardware config menu in pangolin, it will give me an error about updating the FB3 to the latest firmware (which I already have done). I have tried switching the USB connection to different ports on the PC, I have even disabled all power saving settings for USB interfaces. I have had this problem on 2 different PC's but I can't remember if they were both Windows 7, but I'm sure I've had the issue since I purchased the device sometime early last year.

    If I unplug the USB cable and plug back in, it usually fixes the problem but if I am in the middle of a show, the damage has been done. I am also running an Entech DMX Pro but I think I added that to my system when I was already having issues with the FB3. Has anyone else had this issue? Is there some kind of idle mode that the FB3 goes into?

    Thanks
     
    Last edited: Oct 7, 2011
  2. vvvetalll

    vvvetalll Member

    What about the USB cable with it all right? Because FB3 wants a good connection and does not like cheap, old or faulty cable. This is especially true update firmware !
    Start with the new cable ;)
     
  3. PhillD

    PhillD Beta Tester

    That is a good point. I have always used the same cable (the one supplied with quick show software). I will swap it out tonight and post back tomorrow.
     
  4. PhillD

    PhillD Beta Tester

    I have changed the USB cord and still have the problem.
     
  5. vvvetalll

    vvvetalll Member

    What is the version of program Quickshow ?
     
  6. smokeAndMirrors

    smokeAndMirrors Well-Known Member

    You need to get in touch with Pangolin directly - there is a link for technical assistance on their website. They have just assisted me fix a problem and are generally extremely helpful.

    Suggestion: have you tried running QS on another computer? If you are running on a laptop, try a tower if you can. If you run Win 7, try on an XP or Vista machine. This will help them gauge whether it's the software, the FB3 or the OS that is the source of the problem. Also of help would be the minimum amount of time of non-use it takes for the laser to stop responding. 10 minutes? Half an hour? One hour? 10 hours?

    Hope you get it sorted!
     
  7. PhillD

    PhillD Beta Tester

    Sorry for the delay in responding. I have the latest version with the latest firmware.
     
  8. PhillD

    PhillD Beta Tester

    I have had the same problem on 2 different PC's. I think the old PC was XP and my current PC is windows 7. Both had Asus boards in them and I didn;t have problem with any other USB. I don't have problems with my entec device, but then, I tend to be using it more than the FB3 as I don't run the laser shows all the time.

    The Time it takes to "time out" does seem to be random. I didn't have a problem with it at all yesterday
     
  9. PhillD

    PhillD Beta Tester

    Almost immediatley after making this post (on the same PC). I reset the FB3. The computer redetected it and I started a laser animation. It immediatley "cut out". The single green light is lit on the FB3, not yellow or red. I will email support and let them know what is happening.
     
  10. PhillD

    PhillD Beta Tester

    Here is a screenshot of the firmware update page when the problem occurs.

    FBIssue.jpg
     
  11. PhillD

    PhillD Beta Tester

    And here is the screen I get when I open Pangolin when the FB3 is messed up.

    FBIssue2.jpg
     
  12. PhillD

    PhillD Beta Tester

    After much back and forth with Pangolin, this issue could have been caused by a combination of a few things.

    I tried all the obvious things like using different USB ports on the PC, changing USB cables, FB3 firmware etc but it came down to 2 things.

    1 I installed a new PCI USB card in my computer and ran the FB3 on it.
    2 I removed a USB extender and replaced it with a longer DB25 cable.

    These 2 things seems to have fixed my issue though I am suspicious it may have been the DB25 cable all along. I had only just started using the extender in the last month but I had been having problems with my setup for the past year. I have to run through a full show before I'm sure the problem is gone but It hasn;t crashed once since I started using the longer DB25 cable.
     

Share This Page