Qm2000.net ld error -1003?

Discussion in 'Networking' started by BillWX, May 16, 2013.

  1. BillWX

    BillWX Member

    Greetings,
    I'm experiencing a weird error. I'm at a college planetarium and we have 3 PCs that have been upgraded to Windows 7. (They worked perfectly fine with XP, but we HAD to get them done...bla bla bla..)
    Anyway, we also upgraded our QM2000 to QM2000.NET. I installed LD2000 onto our main theater PC and all is perfect. We plug the QM2000.NET, the computer finds it and we go on our merry way.
    But upon installing on either of the other PCs (in our workroom for production), we plug in the QM2000.NET box and upon launching LD2000, we get "LD status/error -1003 QM2000 Initialization problem detected" and the program exits. I've run the QM2000.net program and it finds the card and address EVERY time. But LD2000 (or Showtime) throws the same -1003 error message.
    Note this is happening on BOTH our workroom computers. I've uninstalled, reinstalled and checked everything.
    This is driving us bonkers! :confused:
    We would really like to be able to bring the QM2000.NET box into the workroom, plug it in and be able to program outside of the theater.
    Does anyone know what the -1003 initialization status/error message is? Or what could be causing it to happen on 2 computers? I've changed the loading to "Win XP" mode and the same error comes up. Is there something I'm missing?
    I've even taken the box home and loaded everything onto my XP computer and it works perfectly fine.
    Thanks for any help anyone can offer.

    -Bill
     
  2. Aaron@Pangolin

    [email protected] Staff Member

    Long Live Windows XP!!!

    In my experience, Windows 7 likes to be a pain when it comes to being network friendly.

    The error code means there is a communication problem between LD2000 and the QM2000; for some reason LD2000 cannot see the QM2000.

    This is usually because of one of a few things; verifying it works on the one computer helps in that it shouldn't be the QM2000 or .NET box. The easiest issues to isolate are an IP address issue or a bad CAT 5 cable. First things, verify your IP address is similar to 192.168.1.99 (or lower) and swap out CAT 5 patch cables.

    If that doesn't work it might take one of us logging into your PC remotely to isolate the problem. IF you can give me a call when you are in front of your laser computer, with the FB3 connected, with the computer connected to the internet, I have an application that will allow me to remotely control your computer and I can do some digging.
     
  3. BillWX

    BillWX Member

    Thanks for the quick reply Aaron! Unfortunately the college will not let anyone else have remote access to "campus computers". And of course they don't know what Pangolin or the QM2000.NET box is. We're better off doing the network stuff ourselves the best we can. (Last time we called someone in to figure out what was wrong, the guy simply completely uninstalled all Pangolin software and said "Now you won't have the conflict." Nice, huh?!)
    We're limited in IP addresses we can use because we're part of a campus network and "they" have to be able to "check" on all the computers from time to time. (It really is a headache. On top of Win7 not being able to do what we could do just a few months ago!)
    The cable is fine. It's the same one we're using in the theater and when I borrowed the box to take home to try on my XP machine.
    At least you narrowed down the error message so it's definitely an address issue. Like I said, if I run the network finder program, it does find the QM2000.NET box and I can change addresses, etc... on it. Maybe we'll have to do that.
    At least the main computer runs fine and we can record shows like normal.
    Thanks again. I'll see what messing with the IP addresses can do to resolve it in the workroom. -Bill
     
    Last edited: May 17, 2013
  4. BillWX

    BillWX Member

    Greetings,
    OK, the problem here has been solved! If anyone has a similar problem as I originally posted, check those DLL files! As it turned out the LD2000.DLL file was missing in the main LD2000 folder (for whatever reason). I copied it there and that pretty much solved the problem. Also, the same file was in the windows/system folder, but was corrupted. So I placed another copy there, just so there was an uncorrupted copy. (LD2000 and Showtime did load without it there.)
    So now, no more -1003 errors and everything loads up fine. :)

    -Bill
     
  5. Aaron@Pangolin

    [email protected] Staff Member

    Hey Bill, glad to hear you are up and running. Windows can do dirty tricks with some of the config files and as always, Windows is just getting better and better... :rolleyes:
     
  6. Pangolin

    Pangolin Staff Member

Share This Page