QsTimeline (txt) problem - can't (couldn't) create shows

Discussion in 'Lasershow Designer QuickShow' started by Andy62, Sep 1, 2021.

  1. Andy62

    Andy62 New Member

    So here's the problem....
    I Install Quickshow and open IT up for the first time and everything works as it should. On closing the program QS creates a QsTimeline.txt file in the QS System folder. If I run the program again I'll get a pop up error box
    stating :.... Cannot open file "C:\QS\System\QsTimeline.txt. Access is denied......... I'll chose the 'continue to open program' option and everything works fine apart from the timeline. If I click on the timeline the error pop up pops up again, and will continue popping up until I click onto a different tab. (the Timeline is blank btw).
    Now, if I delete the QsTimeline txt file before I open QS,everything works fine.
    This is on a Windows 7 drive. I've installed QS to a Windows 10 drive and no such problem occurs.

    Why is it doing this on W7? I've not played with my lasers for a good few years but I never used to have this problem. Just looking at my original disc I started using it when it was version 2 :)

    I've made a little workaround exe to delete that timeline txt file and then open QS....but it would be nice if I didn't have to. Could the developers include such a thing in a future update? :D

    I did get an email from support suggesting I updated to the latest version as he could see from the report sent I was using an earlier version of QS and this was probably a one off problem. Well I've probably tried it on 4 or 5 different updates going back to version 4 and it's there on them all.
  2. Bob@Pangolin

    Bob@Pangolin Staff Member

    When you run QuickShow and you open windows task manager (By right clicking on the task bar) , check the process QuickShow, what is the name of the user that is executing QuickShow?

    Next after the text file has been written, right click on the file to open the information panel, who is the owner of the file?

    Does it match with the one that is executed QuickShow?

    Is this the same name of the user that is signed in on the computer?
  3. Andy62

    Andy62 New Member

    Hi Bob.
    Yes, they all match. The first thing I did when I saw the access denied message was to take over ownership and get full control. It didn't make any difference though.
  4. Bob@Pangolin

    Bob@Pangolin Staff Member

    Very strange. I have never seen this before.

    Make sure you are on the latest version.
    Make sure you are local administrator on your PC

    If it keeps doing that please report an issue to support [at] pangolin [dot] com.
  5. Andy62

    Andy62 New Member

    Just my luck. :D

    Well, thanks for trying to help Bob. I'm on version 5 - build 1545, i'm the admin, owner etc etc, so its a mystery.
    I've just sent off a fresh error report, for what its worth.
  6. Andy62

    Andy62 New Member

    Update - Problem solved

    With help and suggestions from support ( many thanks Aaron ;)) I uninstalled my 'iobit Maleware Fighter' program and all the problems went away. I re-installed it and everything seems to be working fine as far as I can tell.
    So,' i'm thinking a file in iobit must have become corrupted and was 'messing' with Quickshow? I haven't had access denied problems with other programs.

    Anyway,,,,happy days :D