Triggering Cues

Discussion in 'Lasershow Designer QuickShow' started by brandonw88, Nov 30, 2013.

  1. brandonw88

    brandonw88 New Member

    Hello, I am pretty new to quickshow but so far it's been great till now.

    I am trying to trigger the quickshow cues from another program, Light-O-Rama, to the Enttec DMX USB Pro however, the Enttec is not reading the proper DMX signals that are being sent to it. I have verified that Light-O-Rama is sending good signals but for some reason the Enttec is not reading it properly and I have the latest firmware installed to. anyway I am wondering if there is any other way i can trigger the cues in quickshow other than with the Enttec or is that the only way?

    the issue with the Enttec is that when i send 3 DMX channels to it, it only reads channel 3 and not reading 1 or 2. I tested it with the light-o-rama DMX console and the Enttec is very inconsistent with its readings. if i move all 16 DMX sliders at once the Enttec shows the proper values received but if move one slider at a time it either sticks to a single value and doesn't change till i drop it to zero or it just automatically drops to zero even though i may have the slider at say 150.

    I am still trying to figure out if my Enttec is bad or not but until I do I would like to find alternate methods of getting Quickshow to work with Light-O-Rama.

    thanks, hope this makes sense
     
  2. Aaron@Pangolin

    [email protected] Staff Member

    QuickShow has MIDI input abilities but they are limited compared to our professional software platform BEYOND.

    The main limitation that is noticeable is the cues in QS are only selectable by mouse or keyboard input. To get a MIDI controller's notes to control cue selection you need a 3rd party MIDI converter to convert the MIDI notes to keystrokes. Unfortunately, I cannot advise what software to use or how to set it up; I only know you cannot go directly from MIDI to select the workspace cue.

    There are many MIDI translators out there; a few have been mentioned on our Pangolin User forum. Here is a specific thread for QuickShow MIDI control: http://www.pangolin.com/forums/showthread.php?t=1502&highlight=MIDI.
     
  3. brandonw88

    brandonw88 New Member

    ok I will defiantly look into that because i know Light-O-Rama is capable of MIDI.
    I have been chatting with Enttec this week about my USB Pro and they sent me a special firmware version to use with QS. this firmware causes QS to lock up when the Enttec is reciving a DMX signal. if I disconnect the DMX cable QS un-freezes instantly and when i plug it back in QS freezes again. this does not happen with the original Enttec Firmware. I am using QS build 374. this is happening on two different computers both running windows 7 64 bit. According to Enttec this firmware was approved by Pangolin and supposedly corrects the input function of the USB Pro between QS. but i can't use it if it causes QS to freeze. can you verify this issue? thanks for the help
     
  4. Stuka

    Stuka Well-Known Member

    Brandon -

    I've used Light-O-Rama with my Pangolin laser gear (LD2000) for a couple of seasons now.
    Right now my LOR gear isn't available for me to confirm this, but I'm pretty sure that the MIDI capability of the LOR system is input only.
    (Unless there has been a recent change to the LOR software).

    Just out of curiosity -
    What DMX controller are you using with your LOR PC to send the DMX signals to your QuickShow PC, and do you have any other DMX equipment in the loop?

    It does sort of sound like you might be having issues with your Enttec DMX USB Pro.
    If you haven't done so already, you might want to test it with the Enttec Pro Utility to make sure the I/O channels are working correctly.
    Start by making sure all the latest drivers and the Pro utility are installed on your PC, then hook up the USB Pro.
    Use the Pro utility test buttons to test basic functionality.
    You should also be able to connect your DMX controller rig to the USB Pro "input", and verify input is working correctly using the Pro utility.

    If the USB Pro does NOT test OK with the Pro utility, you probably need to do some more troubleshooting with your USB Pro ~ sometimes a USB cable swap works wonders!

    If USB Pro checks out OK with the Pro utility, launch QuickShow, open the DMX settings, and run the "Test Connection".
    If the USB Pro tests OK, you should be able to move forward with setting up your cues per the Quickshow "DMX Input Settings" tab.
    If the USB Pro STILL doesn't test under Quickshow, you have at least isolated where you need to start your troubleshooting.

    FWIW, I've been using my USB Pro on a Windows 7 64-bit laptop with the latest download version of Quickshow, and for DMX "output" from QS it works fine. However, I haven't tried using the USB Pro for DMX input to QS.

    You've probably already found out that configuring DMX control on the LOR system takes a bit of "tinkering", but once everything is set up, it works quite well!

    Concerning MIDI control of Quickshow -

    As long as your PC has a some sort of MIDI input driver installed, cues can be triggered in Quickshow directly by MIDI note messages.
    The MIDI channel tells QS which page to use, and the MIDI note tells QS which cue to trigger.
    So, you could potentially have up to 16 pages of 60 MIDI-addressable cues per page!! Works great!

    (I actually used this over Thanksgiving to trigger some DMX-controlled lasers, using my iPad as a MIDI controller linked via a MIDI interface directly to QuickShow - no other software required :))

    Randy
     
    Last edited: Dec 4, 2013
  5. Aaron@Pangolin

    [email protected] Staff Member

    I suggest rolling back the firmware. I tested the one that resolves the lock up issue and it works well. If you did not have an issue, changed the firmware, and now have an issue, try to roll back the firmware.
     
  6. brandonw88

    brandonw88 New Member

    Thanks Randy, so i am using the LOR iDMX to send the signal to QS via the Enttec USB Pro input. I have tested the Enttec device with the Enttec Pro Manager and it shows the correct DMX values received by LOR however QS doesn't seem to respond consistently. as for the firmware I have rolled back to the previous version and it doesn't freeze QS. I will keep playing around with it and see what i can do. thanks for the help
     

Share This Page