Bugs / missing functionality after migrating from QS3 to QS4

Discussion in 'Lasershow Designer QuickShow' started by gsuberland, Aug 16, 2018.

  1. gsuberland

    gsuberland Member

    Hi,

    I've been working on a number of laser shows in QS3 and noticed that QS4 was out, so I thought I'd give it a go. Unfortunately I've run into a few issues relating to the QuickTimeline view in QS4.

    To start out: I'm running QuickShow x64 version 4.0 build 1093 on Windows 10. I'm running an FB3 controller and it has been updated to the latest firmware.

    The first and easiest to demonstrate bug is that the waveform view cuts off about half-way across when zoomed in. This appears only to occur when the window's horizontal size is particularly large - I run it full screen on a 4K monitor with window scaling disabled, so the window is a full 3840 pixels across when maximised.

    waveform_not_fully_displayed.png

    Credit where credit is due, though, QS4 did fix the issue where maximised windows slightly spilled over onto adjacent monitors on multi-monitor setups!

    The second bug is harder to demonstrate but the "4 discrete steps" option doesn't appear to work correctly, at least when applied to zoom effects on animations. It appears to create 5 steps instead of 4. I haven't tried replicating this on any other type of effect yet as I only noticed it when playing back a show.

    four_steps_is_five_steps.png

    four_steps_issue_settings.png

    In QS3 this effect played 4 steps just fine with each size step on a 2-unit boundary, but in QS4 it appears to be stepping on a smaller timescale leading to off-beat timings and an erroneous 5th step.

    Finally, not so much a bug as functionality that existed in QS3 but disappeared in QS4, the QuickTimeline no longer allows the use of Shift+Scroll to move through time, or Ctrl+Scroll to zoom. I tend to quickly zoom in and out a lot as I move between parts of the show, so it's frustrating to have to click the Zoom +/- buttons on the screen instead of just using my scroll wheel.

    Let me know if you need further info or screenshots.

    Thanks,
    Graham
     
  2. Bob@Pangolin

    Bob@Pangolin Staff Member

    Could you update to the latest version of QuickShow using the update button in the top right bar and see if the problem still exists?
     
  3. gsuberland

    gsuberland Member

    Ah, I downloaded from the website and assumed that would be the latest one.

    Having just updated to build 1096 I can confirm that the scrolling issue appears to have been fixed (controls are different but I can live with that) but the waveform display issue and 4-step timing issues are both still present.
     
  4. gsuberland

    gsuberland Member

    To expand on the waveform issue, it appears that even when fully zoomed out the waveform will only go as wide as 2048 pixels. Things go wrong when the window is resized such that the width of the timeline exceeds that. My guess is that this wasn't tested on a 4K monitor.

    I also identified a second bug relating to window size, although it's not likely to occur in most use-cases. Trying to stretch the window beyond about 10,000 pixels wide causes the application to crash. No crash log is created from what I could see. This is only likely to occur if someone tries to run QS on a triple-head 4K monitor setup. I'm not too worried about this bug as I only ran into it when I was actively seeking out interesting UI bugs at high-res.
     
  5. ENOT

    ENOT Software Developer Staff Member

    QuickSnow is NOT high DPI application. Executable declare this flag. When you disable window scaling you provoke this problem. To avoid this problem, next build of QS, max width of main window will be limited to 2560, what is max size of iMac 5K screen with enabled scaling. There is technical limitation of the framework. It may change in the future, however, currently QS will stay "low" DPI resolution application. Second technical limit is size of bitmap. It is impossible to make 10`000 pixel width bitmap. Anyway, QS work correctly on standard 1092x and 2560x resolution. Bigger width is not technically possible.

    Waveform. Waveform definitely work correctly. What might be a reason of what you experience is a calculation mode, that should not be used in QuickShow. Technically, QS 4 based on BEYOND 4 code, and has much more options than QS 4. Please send to me your show file, I will check out what is going on internally. And, thank you for detailed explanation in screenshot, really appreciate it.

    Timeline mouse wheel. Mouse wheel without any extra key work as zoom in/out, with zoom center at mouse position. With CTRL, the wheel move timeline left and right. And, pay attention, new scrollbar on a bottom has two action depending on button - left or right. Left for mode detailed navigation, right for quick scroll.
     
  6. gsuberland

    gsuberland Member

    I'm unhappy with this as a solution. I've been using QS3 on my 4K monitor in full screen mode for a long time and have not run into problems with the waveform rendering or anything else, so I fail to see how this is a limitation of the framework. These issues were introduced with QS4, seemingly with the new timeline control.

    The 2560 pixel width limit seems like patching the symptom rather than patching the underlying rendering problem, and it isn't really compatible with modern hardware. 3K (2880x1620) and 4K (3840x2160) resolution panels are becoming more common in high-end business laptops (including mine), and this "fix" would make it impossible to use QS in fullscreen mode on them. In fact it would mean that I no longer have the ability to use QS effectively on that laptop to do live shows, and it would be frustrating to use on my desktop when designing shows too.

    Sorry, but I respectfully disagree. Bitmaps have an unsigned 16-bit integer width parameter, so the maximum width is 65535 pixels. This is the case with TBitmap even going back to Windows 95, upon which only the old DIB format is supported for in-memory GDI bitmaps. However this isn't really important since the issue only occurs with extremely wide windows - I only noticed it because I was going out of my way to look for other bugs that might help narrow the issue down.

    Sure, no problem. Drop me an email - the address is (my forum handle) at (gmail dot com) - and I'll reply with the show file.
     
  7. ENOT

    ENOT Software Developer Staff Member

    OK, are you software developer? Just need to understand how to talk.
     
  8. gsuberland

    gsuberland Member

    Yup. Infosec / reverse engineer by trade with a dev background.
     
  9. ENOT

    ENOT Software Developer Staff Member

    Could you please send the show to support@pangolin.com?

    regarding other questions - it would be wrong to argue with clients.
     
  10. Istvan Farkas

    Istvan Farkas New Member

    Hi!
    I refreshed it Quick Show software onto 4 versions.
    The projector does not work unfortunately after these.
    FB3 a LED emits yellowish light when he should be green.
    What may be the correct setting?
    Thanks: István
     
  11. Bob@Pangolin

    Bob@Pangolin Staff Member

    Did you press enable laser output? .. Yellow means ready to laser.
     
  12. Istvan Farkas

    Istvan Farkas New Member

    Hi bob!
    The laser output allowed. It did not cause the problem. I installed the new software again, the projector works.
    Thank you for your answer.
    Best regards: István