MIDI Controllers Work Randomly In Beyond

Discussion in 'Lasershow Designer BEYOND' started by smarmar, May 4, 2019.

  1. smarmar

    smarmar Member

    I'm wondering if anyone else is having trouble getting MIDI controllers to work correctly in Beyond.
    I have two off-the-shelf controllers, both connected to the computer via USB. Both devices are listed in MIDI Settings and both device profiles are loaded. Everything is set correctly; however, there is a seemingly random chance that both controllers will either work or both will not work. This happens on any computer I have that's running Beyond. I can restart Beyond and/or reboot the computer, keeping all hardware connected as before and the outcome can be different (they'll work or they won't work). I've tried rearranging the USB plugs, powering on devices in different orders, relisting the devices and reloading their profiles in Beyond, and updating Beyond. I just don't know if the issue is related to Beyond, Windows 10, or something else; I have no constant by which to troubleshoot the problem.
     
  2. Bob@Pangolin

    Bob@Pangolin Staff Member

    Did you already try to connect the Midi controllers through a powered USB hub?

    Currently there are no open or known issues with BEYOND and USB Midi devices.
     
  3. smarmar

    smarmar Member

    I've been using a non-powered USB hub. I'll try using a powered hub and see if that makes a difference.
    Thanks.
     
  4. smarmar

    smarmar Member

    I was reminded by someone who's been working on this issue with me that we were using a powered hub earlier in the troubleshooting process but still getting the same results. Someone in another forum had this to say:
    If connection is lost for a second / packet is dropped, it might need to initialise for it to work again.

    They were referring to me using wireless transmitters/receivers. For my purposes I need to have the devices be wireless, so wired controllers are not an option. Strangely (or maybe not), our AKAI APC40 MKII wired controller works flawlessly (as long as it's powered on before launching Beyond).
     
  5. Alex Fischer

    Alex Fischer Member

    Hi, I don't know what happened, but since today I see the same manner with my Akai APC 40 MK II. It works for month with any issue. Now I see that it works for some button push before the Akai is ignoring every Input.
    Any help is appreciated.
    Alex
     
  6. Bob@Pangolin

    Bob@Pangolin Staff Member

    Hi alex, did you try a powered usb hub? And are you using the latest version?
     
  7. smarmar

    smarmar Member

    I think the problem has been remedied (at least, as best as it can be).
    A mind more powerful than my own deduced that the anomaly was caused by me using an identical (brand /model) wireless transmitter/receiver in each of my devices. The devices work flawlessly now if they're powered on before Beyond launches and if the computer "sees" the devices in the order in which they appear in Beyond's MIDI Settings device list. If the computer puts them in a conflicting order at bootup I have to swap the order in the device list, then the devices work fine. I'm thinking the problem wouldn't exist if I use two different brands/models of transmitters/receivers.

    TILDR: The order in which the USB devices are initially detected by the computer during bootup might conflict with the order of said devices in which Beyond needs to see them.
     
  8. Alex Fischer

    Alex Fischer Member

    Hi Bob,
    the midi device is connected via a powered usb hub. And in this in combination it worked since months. Now I connect the Akai midi device directly to the usb connector in the Laptop. And it seems that it is working better now. Better means, that it works as Long as I didn't push the SHIFT knob on the akai midi device. After pushing the SHIFT knob, I have to Restart the pangolin application.
    I don't know, but something has changed … not in my configuration.

    Regards
    Alex
     
  9. Bob@Pangolin

    Bob@Pangolin Staff Member

    Hi Alex,

    You might want to try reloading the profile.

    That you can do is to open the Midi configuration panel so that you are in this window:

    Screenshot 2019-06-16 at 18.20.34.png

    (Settings >> Midi >> Device settings >> click configure under the active controller.)

    Then click open and open the APC40 template that you need. It will reload the template settings in BEYOND.
    There are currently no known issues in this area, so at the moment, it's guessing what the cause can be.

    It could even be the usb cable.

    - Try another USB cable
    - Try another APC40
    - Are you on the latest version?
     
  10. Alex Fischer

    Alex Fischer Member

    Hi Bob,
    Ok I'll try another usb cable. Trying another APC40 isn't possible unfortunately.
    What do you mean with latest Version? Of Beyond? I'm using build 1182 (4.0)

    Greetings
    Alex