qm2000.net and Win8 Beyond/LD2000

Discussion in 'QM2000 series of products' started by Richi, Jan 5, 2014.

  1. Richi

    Richi Member


    i see that ld2000.dll are only allocated if is in windows/SysWOW64/ if is in other directory windows/system32 or is it in beyond directory then are not allocated from beyond.exe

    But the Microsoft reglementation of access rules, are not allowed override the rights of datasets inside of this directorys...
    ld2000.dll are not a trusted dll from microsoft, now it haves no rights for right execute.
    I have set rights that allow all users, tasks, network, but windows dont allow this.
    This is different to windows7 !!
    Programming beyond clear, with a new ld2000.dll that is allocated inside the beyond directory, and i am shure thats work.

    By the way.... sysWOW64 is windows on windows... it is for communication over time critical networking a very bad solution.

    Programming a clear 64bit version, i am shure that works.
    I have not tested with 32bit... i dont have it.

    You can contact me over icq or mail then can you see it live with teamviewer.

    I am not alone with this error... i know other people who have the same.
    But other people have all downgrade to win7 32bit ;-)

    I dont want downgrade, i need 64bit adressing .. more RAM adressing ;-)
  2. Aaron@Pangolin

    Aaron@Pangolin Staff Member

    Hey Richi; I have a local Client that seems to be having a similar issue. Two separate Windows 8 computers are unable to connect to multiple QM2000.NET boxes. This Client will be shipping one of the computers to our US office so we can isolate the issue. I cannot be sure that his issue is the same as yours but they appear to have the same symptoms. Once we have a solution for his computer that we can apply successfully to his second computer I will post it for you to try.
  3. Richi

    Richi Member

    Hi Aaron, thanks for Information. I hope/think its same.
    I have today bekome it on one Computer working. Not shure what is the difference.
  4. Pangolin

    Pangolin Staff Member

    For sure your problem has nothing to do with the LD2000.DLL.

    Moreover, our DLL ****ABSOLUTELY IS***** trusted by Microsoft, and it is a signed DLL.

    If the DLL itself was a problem, BEYOND would be complaining that it could not locate or open the LD2000.DLL. That is not happening. Therefore your prognosis that your problem is related to the LD2000.DLL is a flawed prognosis.

    Your particular problem ****MAY**** be related to changes originally made in Windows VISTA -- changes which are unfortunately still plaguing the latest versions of Microsoft operating systems. For more information, see this video:

    At this point there are nearly 14,000 LD2000 users in the field, absolutely most of them working with no problem. Every once in a while, a user will report problems along the lines of what you are reporting. Often times we find the cause is third-party software installed on the PC. For example, if you have ANYTHING with the word "Norton" in it, we would strongly recommend you completely remove it from your PC.

    Other than that, I can say that it is difficult for us to find every problem through simple word communication in forum posts and emails and, in extreme cases, we need clients to send the PC directly to Pangolin so that we can install advanced debugging tools and diagnose and then solve the problem.

    If this is an option for you, then we should get into a discussion of how to ship your computer so that we can begin the process.

    Best regards,

    William Benner
  5. Richi

    Richi Member

    And who wrote this into ld2000.ini ??

    [LD2000 Network]
    Default IP Address=

    and this to the C\Users\username\AppData\Local\VirtualStore\Windows\ld2000.ini and not to c\windows\ld2000.ini

    If you run LD2000 with admin rights, then have access to c\windows\ld2000.ini

    only when the option programs do not have the full right, wrote windows it to the virtualstore

    Beyond starting and use always the file in C\Users\username\AppData\Local\VirtualStore\Windows\ld2000.ini
    Last edited: Mar 16, 2015
  6. Pangolin

    Pangolin Staff Member

    Those entries are created by the LD2000 Network application (LD2000_Network.exe found in the LD2000\Network folder). This is an application that SHARES A LOCAL (i.e. located on the PCI bus of your computer) QM2000. There is a text file in that same folder that explains its usage.

    You should **** NOT **** run the LD2000 Network program if you have a QM2000.NET. This program is only used by people who have computers with local QM2000 installed in the PCI slot. It basically makes a PC pretend to be a QM2000.NET.

    Regarding this "run as administrator or not", we really do not believe this has anything to do with the problem.

    Nevertheless, we are making changes in LD2000 version 5.60, which will be released soon. One of the goals of LD2000 version 5.60 is to get around this "men in black" problem.

    Best regards,

    William Benner
  7. A__M__S

    A__M__S New Member